[Win10, VMware 15.x] How to remove "Virtual Machine: yes" from task manager

This is just a quick tutorial to teach you how to remove “Virtual Machine:yes” from task manager in windows 10. I can’t confirm it will work for windows 8 but I will assume it will. Make sure your VM is fully powered off.

  1. Open your VM’s .vmx file with notepad++
  2. add the following lines in;

hypervisor.cpuid.v0 = “FALSE”
vhv.enable = “TRUE”
vpmc.enable = “TRUE”
mce.enable = “TRUE”
vhu.enable = “TRUE”

It should look like this:

(no it doesn’t need to be in the same order as in the photo T_T)

After this save changes and navigate to your VM hardware settings tab, click the processors option and be sure both of these are checked.

  1. Virtualize Intel VT-x/EPT or AMD-V/RVI
  2. Virtualize CPU performance counters.

After you’ve successfully followed the steps above your VM’s task manager should be saying this:

Congratulations! You’ve successfully hidden your VM from task manager!

Happy baitin’!


Awesome - thanks for that oft-elusive guide (just what I was looking for)!; I also add in:
SMBIOS.reflecthost = “TRUE”
To make SysInfo report back something more like your real hardware…


Just a remark, I recently found out that the content in the vmx-file is case sensitive:

SMBIOS.reflecthost = “TRUE” didn’t work.
SMBIOS.reflectHost = “TRUE” did work

FYI: I’m using VMware Workstation 16 Player

1 Like